Перейти к публикации

Рекомендованные сообщения

Здравствуйте, коллеги!

Помогите, пожалуйста, разобраться в чём может быть дело?!

Такая ситуация: в ручном управлении перемещения Z нажимаю стрелки вверх/вниз , а двигатель начинает дёргаться и хаотично вращаться в разных направлениях (по часовой и против часовой).
Что это? И в чём может быть проблема? Подскажите, пожалуйста.

Подключал двигатель Z к оси Х - он работает как надо.
Менял провод Z - всё равно двигатель дёргается.

Ссылка на сообщение
Поделиться на других сайтах

Для наглядности снял 

Сделал на валу белую метку, чтобы было видно, как двигатель хаотично дёргается.

Ссылка на сообщение
Поделиться на других сайтах

@Юрок померяй напряжение тестером между красной и белой стрелкой( белая на пятой ножке микросхемы,) попробуй добавить ручным резистором(синяя стрелка)

визуально посмотри на драйвер( ну для наглядности фото скинь) 

12 часов назад, Юрок сказал:

Подключал двигатель Z к оси Х - он работает как надо.

провода исключаем, что то с драйвером.  

Без имени-1.jpg

Изменено пользователем minus
  • Одобряю сказанное 1
Ссылка на сообщение
Поделиться на других сайтах

@Юрок блин ,была такая хренатень только по Y много крови мне попило, менял драйвер как он там l627 кажется но проблема была не в нем, проблема была в ...я не знаю как называется эта микросхема или тоже драйвер ,потом могу фото скинуть, она тоже черная маркеровку не помню , не припаяна как l627  а в "каритце" таком сидит ,я  ее просто с другой поменял,помоему по z  и проблема ушла, в идеале конечно заменить ее нужно

  • Нравится 1
  • Одобряю сказанное 1
  • Не одобряю сказанное 1
Ссылка на сообщение
Поделиться на других сайтах

@Юрок ,в норме напряжение по z должно быть 1,3 вольта (пятая ножка микросхемы и масса, как показал @minus )

Ссылка на сообщение
Поделиться на других сайтах

Посмотри на шлейфе не оторвался ли проводок. Попробуй поставить дополнительное заземление на корпус станка.   L297 тоже может быть. А вообще похоже на плохой контакт. Например одной стороной кабель будет чудеса вытворять, а другой норма.

Изменено пользователем древний
Ссылка на сообщение
Поделиться на других сайтах

@minus , @Мойша Степан , @древний пока напряжение не померил, но определил, что причина кроется в плате, т.к. ставил плату с другого станка, и Z работает как надо. 
Поставил обратно плату,  но заменил L297 (поменял местами: с Х поставил на Z), 
Нажимаю на перемещение Х - всё ОК! 
Z  уже не дёргается (как на видео) , а хотя бы перемещается. Но! Перемещается тоже не корректно!
Нажимаю "вниз", он поднимается вверх, затем нажимаю "вверх" он снова поднимается вверх... В общем, куда бы я не нажимал, Z поднимается/опускается куда ему заблагорассудится. 

 

29.05.2020 в 10:55, dexter 2015 сказал:

проблема была в ...я не знаю как называется эта микросхема или тоже драйвер ,потом могу фото скинуть, она тоже черная маркировку не помню , не припаяна как l627  а в "корытце" таком сидит ,я  ее просто с другой поменял, по-моему по z  и проблема ушла, в идеале конечно заменить ее нужно


@dexter 2015 , скинь, пожалуйста, фото этой чудо-микросъемки-драйвера. Рассмотрю её тоже...

Ссылка на сообщение
Поделиться на других сайтах

@Юрок вот я красным обвел, опробуй местами поменять, такая же хрень с движком по игрику была, крутит крутит потом как бы закусывает и в другую сторону начинает крутить

299972489_-1.jpg.b7ec8331ed0c3675275b751404288b3a.jpg

  • Не одобряю сказанное 1
Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, dexter 2015 сказал:

опробуй местами поменять, такая же хрень с движком по игрику была, крутит крутит потом как бы закусывает и в другую сторону начинает крутить

@dexter 2015 , поменял. Написал об этом выше...

13 минут назад, Юрок сказал:

Поставил обратно плату,  но заменил L297 (поменял местами: с Х поставил на Z), 

 

Ссылка на сообщение
Поделиться на других сайтах
29.05.2020 в 10:55, dexter 2015 сказал:

@Юрок блин ,была такая хренатень только по Y много крови мне попило, менял драйвер как он там l627 кажется но проблема была не в нем.

@dexter 2015 , а "l627" это которая?

Изменено пользователем Юрок
Ссылка на сообщение
Поделиться на других сайтах

@minus @Мойша Степан @древний @dexter 2015 , сегодня померили напряжение  (пятая ножка микросхемы и масса, как показал @minus ). Всё в порядке.
Но Z отказывается работать как положено. В чём может быть ещё причина? Подскажите, пожалуйста.

 

Изменено пользователем Юрок
Ссылка на сообщение
Поделиться на других сайтах
3 минуты назад, minus сказал:

сколько показывает напряжение? 

@Юрок 

@minus  1.3

@minus 

Я  перекидывал L297 с Х на Z.
В этом случае Х работал как надо (со стоящим от Z L297), но Z всё равно чудил (с установленным L297 от Х).
Значит делаю вывод, что проблема не в  L297. 
На что ещё могут быть подозрения помимо L297 ?

Ссылка на сообщение
Поделиться на других сайтах

понижать или повышать пробовал? 

до 0.98 попробуй. 

ну и фото платы скинь, так сказать провести внешний осмотр.  

Ссылка на сообщение
Поделиться на других сайтах

@minus , да. И повышал и понижал - никакой разницы! Всё равно крутится и плохо, и разнонаправленно.

@minus 

1.jpg

2.jpg

3.jpg

Изменено пользователем Юрок
Ссылка на сообщение
Поделиться на других сайтах

@Юрок  а сам двигатель Z вручную прокручивается нормально?  не "закусывает" ?  

может ШД  не исправен, либо потеря контакта (или плохой контакт) в его проводе соединяемым с магистральным проводом Z. 

 

14 минут назад, Юрок сказал:

Значит делаю вывод, что проблема не в  L297. 

получается так 

Изменено пользователем minus
Ссылка на сообщение
Поделиться на других сайтах
10 минут назад, minus сказал:

@Юрок  а сам двигатель Z вручную прокручивается нормально?  не "закусывает" ?  

может ШД  не исправен, либо потеря контакта (или плохой контакт) в его проводе соединяемым с магистральным проводом Z. 

Когда я ставил плату с другого станка, то двигатель Z работал хорошо и исправно, соответственно исключаю из возможной причины: двигатель, провода, разъёмы.
Поэтому причина в плате... А вот где именно... вот тут вопрос!

@minus Ещё заметил, что когда нажимаю на перемещение Z, и он чудит, то из ящика ПУ исходит лёгкий запах жжёной проводки. Может где-то замыкает? Как проверить где именно?

Изменено пользователем Юрок
Ссылка на сообщение
Поделиться на других сайтах
49 минут назад, Юрок сказал:

Я  перекидывал L297 с Х на Z.

ты перепаивал микросхемы?:aai: я просто не пойму , как это перекидывал? :crazy:

 

 

это не окислы на плате? 

и что за темное пятно на процессоре? 

1ё111.jpg

я написал перекинукть провода , не получится, там шаг винта разный , двигатель не корректно будет работать. 

прям загадка загадка какая то. 

 

 

Изменено пользователем minus
Ссылка на сообщение
Поделиться на других сайтах
30 минут назад, Юрок сказал:

и он чудит, то из ящика ПУ исходит лёгкий запах жжёной проводки.

вот эти товарищи не горячие? 

 

1ё111.jpg

Ссылка на сообщение
Поделиться на других сайтах
1 час назад, minus сказал:

ты перепаивал микросхемы?:aai: я просто не пойму , как это перекидывал? :crazy:

@minus , нет не перепаивал. Просто эту "сороконожку" вынул из гнезда и поменял местами с Х.

1 час назад, minus сказал:

это не окислы на плате? 

и что за темное пятно на процессоре? 

Нет, это видимо бликануло так. Там, наверно, от паяния поблёскивает...
А на процессоре действительно пятно по середине. Честно говоря, не знаю от чего.

1888310747_1111.jpg.a61109d0605464386edad0bf07c06066.jpg.a91a08e826acc3885a8ff8cbeda0cd17.jpg

Проверил этих "товарищей"! 
Нижний, из которых ты обозначил, горячущий!
Причём, он моментально стал горячим после включения станка.
А верхний холодный.
Кажется причина уже близка...

Процессор поближе сфоткал...

4.jpg

5.jpg

Ссылка на сообщение
Поделиться на других сайтах

@Юрок  значит который холодный выходной драйвер крякнул. Меняй сразу парой. Вот тебе и причина.99,99% Я выписывал на Али 

  • Одобряю сказанное 1
Ссылка на сообщение
Поделиться на других сайтах

@Юрок прям слушаю твои проблемы и вижу себя месяца 4 назад вроде,один в один, сколько же мне они говна подкинули, но и опыта,история долгая, ЕСЛИ СУТЬ ТО Я ЛЕЧИЛ СИМПТОМЫ А НЕ БОЛЕЗНЬ ТАК СКАЗАТЬ,  началась с того что начал замечать что греется движок (кстати я перепутал ,по х  проблема была) греется не хренова(станок покупал бу , и с самого начала заметил что по х какая то хрень) после года работы начал издавать странные звуки по х, как будто тяжело движку, не буду описывать мои размышления, муки и капания но в итоге я 4 раза перебрал ШВП, ВЫТАСКИВАЛ ВСЕ ШАРИКИ, промывал , смазывал, засовывал их пинцетом в смазку, научился делать это все как профи:biggrin:просто подумал что давление на движок идет потому что трудно двигаться по винту головке и проблема в швп.....не помогло.... потом долгая разборка с соостностью(еще при покупке заметил что на этом станке если руками двигать по х то очень туго, в сравнении  у меня еще один 7.2( а этот 8) так в 7.2 намного легче....соостность правда была не к черту! головка ударная стояла относительно вала хер знает как , уже не помню всех действий, но она по сути выгибала вал и по этому одна из причин что по х туго шло.

 Короче сделал хренову тучу ДЕЙСТВИТЕЛЬНО ПОЛЕЗНЫХ телодвижений, но в моем случае они не помогли,(хотя по х стало двигаться намного легче)  и вот потом запахло горелым! это была микросхемка или как там ее,(обвел синим) , ОНА ПРОСТО НАБУХЛА И ТРЕСНУЛА(ЧТО РАНЬШЕ НЕ ЗАМЕЧАЛ) ....Я даже обрадоался ,мол вот и суть проблемы. Нашел ее в нэте в магазе в чип дип и не стал заказывать по нэту а сам рванул в ближайший офис  в Гомеле(сам я  с  Брянской области ,100 км от границы 3 государств) купил детальки, приехал , перепаял........ух думаю вот и все проблемы........сгорела.....дым из блока ........короче где то на форуме наткнулся что может быть дело в той детальке что красным обвел,просто поменял ее местами с z, и все прошло,работаю уже не один месяц и все нормально.

    Очень уж похожи твои неполадки, может у тебя в этом "корэтце"  ии контакт в нем не впорядке.

p/s

часто ,на форуме читал НАСТРОИТЬ СООСТНОСТЬ НАСТРОИТЬ СООСТНОСТЬ но хрен один человек нормально это описал , пока сам не допёр,хотя может конкуренция и правильно делают)))

1888310747_1111.jpg.a61109d0605464386edad0bf07c06066.jpg

кстаити на картинке не ту самую, эта вроде по z , просто обозначил где находится

  • За умную мысль 1
Ссылка на сообщение
Поделиться на других сайтах

@minus @kalistratoff @dexter 2015 , спасибо, ребят, что откликнулись! 
По-ходу точно в этих штуках проблема! Как заменим, по результату отпишусь тут. 

Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас
  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×
×
  • Создать...