Перейти к публикации
Thanatoz

Смещается каретка по оси Х

Рекомендованные сообщения

Добрый день всем. Попросили меня посмотреть станок одного знакомого. 



В нем такая проблема: Во время гравировки каретка смещается постоянно в
лево. 



Как это происходит: поставил портрет набиваться, установил начало координат,
нажал запуск и станок начал производить звуки. 



Сначала каретка идет к первой точке, отмеряет высоту, все нормально.
Начинает бить рисунок, и в тот момент когда каретке нужно двигаться в право,
она гудит и стоит на месте, но при этом программа думает что станок работает
нормально, приходит время идти в лево и он свободно двигается в этом
направлении, снова на право и снова гудит и не идет, снова в лево и снова
нормально. Надеюсь нормально все раскрыл. 



Соответственно после нескольких строк каретка просто упирается в левый
борт. 



Сразу скажу что иногда каретка нормально едет в правую сторону, но на следующей
строке снова тупит. 



Пробовал двигать каретку в ручном режиме, через пульт, ни каких проблем не
возникает, ни в одной оси. Проблема с буксованием происходит именно во время
работы. 



У кого есть предположения что это может быть? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Проверил мощность блокпитания: 450. 



Поменял местами шлейфы X и Y и запустил. Начал тупить двигатель Y. Так что
проблема либо в плате либо в блоке либо в программе. 



Кстати провода проверил все, видимых повреждений нет. 



Температура в помещении не минусовая. +10 где то. 



сейчас залез в программу Грейв и увидел что шаг стоит на 300, а частота 255,1 О_о

попробовал понизить частоту до 90, вроде бы пробил рисунок без проблем. Но потом решил удостовериться и снова вернул 255,1 и опять ни каких проблем не возникло. 

Сейчас опять спустил частоту до 90, пусть так и будет стоять, учитывая что второй станок у них вообще выставлен на частоту 75. 

Поставил большой рисунок, бьет в данный момент без проблем, но вот что то меня терзают смутные сомнения. 

Возможны ли смещения из за частоты высокой? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вариантов масса...Нет смазки в ШВП и каретках или забились грязью (возможно они пережаты), износились муфты, небольшой перекос движка или каркаса станка...Попробуй ещё скорость 150-180 поставить. А еще вот здесь почитай может что полезное найдешь.

%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B-%D0%BF%D0%B5%D1%80%D0%B5%D0%BC%D0%B5%D1%89%D0%B5%D0%BD%D0%B8%D1%8F-%D0%BF%D0%BE-%D0%BE%D1%81%D1%8F%D0%BC/">http://graverstone.ru/topic/1175-%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B-%D0%BF%D0%B5%D1%80%D0%B5%D0%BC%D0%B5%D1%89%D0%B5%D0%BD%D0%B8%D1%8F-%D0%BF%D0%BE-%D0%BE%D1%81%D1%8F%D0%BC/

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А станок какой???

Проблема не в плате. Нагрузка идёт на мотор и он не может прокрутить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Господа, я уточняю, поменяв шлейфы местами, проблема с
одного мотора перепрыгнула на другой, так что это точно не мотор и не
направляющие и не ШВП :) я как узнал, тот кто раньше на них работал, не особо о
нем заботился, заземления нет :) 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кондёр менять.Писали уже и не раз.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если шлейфы менял, то конечно это не механика а в плате. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Победил аналогичную проблему по оси Х.

Симптомы:

При ручном перемещении в быстром режиме стала издавать громкие страшные звуки, а в медленном не всегда могла сдвинутся с места.  При печати периодически смещалась в лево.

При перекидке проводов Х - У, проблема перешла на У.

 

Лечение:

Замена контролера шагового двигателя проблему не решила.

Перепаяли микросхемы, которые стоят на радиаторе. На каждую ось по 2 штуки. Заменили по оси Х две микросхемы (350 руб/шт), проблема закончилась.

А перед этим у меня кулер на плате стал притормаживать, временами останавливаться и греться.

Кулер обслужили, а вот микросхемы то ли перегрелись, то ли просто совпадение.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить в тему...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.


  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

×
×
  • Создать...